RB螺纹钢期货论坛-期货交流区

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 3409|回复: 1

听说你们都喜欢指标公式,那不如一起搜集吧?

[复制链接]

8

主题

9

帖子

584

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
584
发表于 2020-8-16 10:40:05 | 显示全部楼层 |阅读模式
此贴供大家专门搜集不错的指标公式所用~
希望大家不吝赐教,将自己觉得不错的指标公式,
或者是网上看到的不错的公式,贴出来
让大家可以一起参考~
回复

使用道具 举报

3

主题

8

帖子

19

积分

初级交易员

Rank: 1

积分
19
发表于 2020-8-16 10:40:51 | 显示全部楼层
      倚天波段王

  VAR1:=REF(CLOSE,1);

  VAR2:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);

  VAR3:=(CLOSE-VAR1)*VAR2;

  VAR4:=SUM(VAR3,0);

  VAR5:=SMA(VAR4,5,1);

  VAR6:=SMA(VAR4,13,1);

  DB:VAR5-VAR6,COLORWHITE;

  CB:MA(DB,4),COLORRED;

  STICKLINE(DB>0,0,DB,COLORRED,1);

  STICKLINE(VAR5-VAR6<0,0,VAR5-VAR6,COLORGREEN,1);

  STICKLINE(DB>CB,DB,CB,COLORRED,0);

  展开剩余93%

  STICKLINE(DB

  QS:CROSS(DB,CB),COLORRED;

  RS:CROSS(CB,DB),COLORGREEN;

  BJ:0,COLORBLUE;

  一笑趋势K线

  QS0:=((CLOSE - LLV(LOW,120)) / (HHV(HIGH,120) - LLV(LOW,120)));

  QS1:=((QS0 / 1) * EMA(CLOSE,20));

  QS:=SMA(QS1,3,1);

  QD0:=((CLOSE - LLV(LOW,119)) / (HHV(HIGH,119) - LLV(LOW,119)));

  QD1:=((QD0 / 1) * EMA(CLOSE,20));

  QD:=SMA(QD1,5,1);

  QF0:=((CLOSE - LLV(LOW,118)) / (HHV(HIGH,118) - LLV(LOW,118)));

  QF1:=((QF0 / 1) * EMA(CLOSE,20));

  QF:=SMA(QF1,5,1);

  PX1:=((((QS + QD) + QF) / 3) + EMA(CLOSE,20));

  PX2:=MA(PX1,2);

  PX3:=MA(PX1,3);

  YY:=((((2 * CLOSE) + HIGH) + LOW) / 4);

  MA1:=MA(YY,45);

  C:=(PX1 - MA1);

  M:=(PX2 - MA1);

  O:=(PX3 - MA1);

  MA2:MA(C,8);

  DRAWLINE((C >= M),C,(C >= M),(O - 0.03),COLORRED);

  STICKLINE((C >= M),M,(O - 0.03),COLORRED,0);

  DRAWLINE((C <= M),C,(C <= M),(O + 0.03),COLORBLUE);

  STICKLINE((C <= M),M,(O + 0.03),COLORBLUE,0);

  LIFELSEE:MA(C,13),COLORGREEN;

  一线定输赢

  XDKX0:=DATE=20051228;

  XDKX1:=EMA(REF(CLOSE,1),10);

  XDKX2:=SMA(SUM(CLOSE,1),3,1);

  DRAWLINE(XDKX2<=XDKX1,HIGH,XDKX2<=XDKX1,OPEN,COLORCYAN);

  DRAWLINE(XDKX2<=XDKX1,LOW,XDKX2<=XDKX1,CLOSE,COLORCYAN);

  DRAWLINE(XDKX2>XDKX1,HIGH,XDKX2>XDKX1,CLOSE,COLORRED);

  DRAWLINE(XDKX2>XDKX1,LOW,XDKX2>XDKX1,OPEN,COLORRED);

  STICKLINE(XDKX2<=XDKX1,OPEN,CLOSE,COLORCYAN,0);

  STICKLINE(XDKX2>XDKX1,OPEN,CLOSE,COLORRED,1);

  一线定乾坤

  C:CLOSE;

  O:=OPEN;

  H:=HIGH;

  L:=LOW;

  TR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));

  A:=EMA(TR,13)*1.2;

  B:=HHV(C-A,21);

  IFELSE((C>B|| C=B),C,B),COLORRED;

  IFELSE(C

  AA:C,COLORYELLOW;

  STICKLINE(C>=O,C,O,COLORRED,0);

  DRAWLINE(C>=O,H,C>=O,L,COLORYELLOW);

  STICKLINE(C<=O,C,O,COLORBLUE,0);

  DRAWLINE(C<=O,H,C<=O,L,COLORWHITE);

  一个很好的指标

  VAR1:=MA(LOW,1);

  VAR2:=MA(HIGH,2);

  VAR3:=MA(CLOSE,2);

  VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;

  VAR5:=SMA(VAR4,3,1);

  Y:SMA(VAR5,3,1),COLORRED;

  Y1:=SMA(Y,3,1);

  VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;

  YI: SMA(VAR6,3,1),COLORYELLOW;

  Y2:=SMA(YI,3,1);

  VAR7:=REF(VAR3,1);

  VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;

  VARB:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;

  VARC:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;

  VARD:=CLOSE*100/MA(CLOSE,10)-100;

  VARE:=IFELSE(VARB>10,10,VARB);

  VARF:=IFELSE(VARE<-10,-10,VARE);

  VAR10:=IFELSE(VARC>10,10,VARC);

  VAR11:=IFELSE(VAR10<-10,-10,VAR10);

  VAR12:=REF(VARB,1);

  VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);

  VAR15:=REF(CLOSE,1);

  VAR16:=100*(CLOSE-VAR15)/CLOSE;

  VAR17:=MA(VAR13,3);

  VAR18:=MA(VAR16,3);

  VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6;

  VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;

  VAR1B:=MA(VAR1A,12);

  VAR1C:=EMA(VAR1A,5);

  VAR1D:=ABS(VAR1A-VAR1B);

  VAR1E:=REF(VAR3,1)*0.015;

  VAR1F:=REF(CLOSE,1);

  VAR26:=MA(CLOSE,26);

  VAR27:=VAR26+2*STD(VAR3,26);

  VAR28:=VAR26-2*STD(VAR3,26);

  VAR29:=VAR26+2*STD(REF(VAR3,1),26);

  VAR2A:=VAR26-2*STD(REF(VAR3,1),26);

  D1:=EMA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

  -2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5);

  D2:=REF(D1,1);

  STICKLINE(D1>=REF(D1,1),D1,D2,COLORBLUE,0);

  STICKLINE(D1

  QR:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100,COLORLIGHTGREEN;

  A:20,COLORCYAN;

  B:80,COLORLIGHTBLUE;

  一个不错的指标

  H:=HIGH;

  L:=LOW;

  HH1:=IFELSE(H

  LL1:=IFELSE(L>REF(L,2)&&REF(L,1)>REF(L,2),REF(L,2),0);

  HH2:=VALUEWHEN(HH1>0,HH1);

  LL2:=VALUEWHEN(LL1>0,LL1);

  K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE

  K2:=VALUEWHEN(K1<>0,K1);

  G:=IFELSE(K2=1,HH2,LL2);

  G1:=VALUEWHEN(ISLASTBAR,G);

  DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);

  W1:=K2;

  W2:=OPEN-CLOSE;

  HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);

  LT:=IFELSE(OPEN

  DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);

  DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);

  DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);

  DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);

  STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);

  STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);

  STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);

  STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);

  DRAWLINE(W1=1&&REF(W1,1)=1,G,W1=1&&REF(W1,1)=1,REF(G,1),COLORGREEN);

  DRAWLINE(W1=-3&&REF(W1,1)=-3,G,W1=-3&&REF(W1,1)=-3,REF(G,1),COLORYELLOW);

  DRAWSL(K2=1,G,0,1,0,COLORGREEN);

  DRAWSL(K2=-3,G,0,1,0,COLORYELLOW);

  HH:=IFELSE(H>REF(H,1)&&H>REF(H,2)&&H>REF(H,3)&&H>REF(H,4)&&L

  LL:=IFELSE(H>REF(H,1)&&H>REF(H,2)&&H>REF(H,3)&&H>REF(H,4)&&L

  H1:=IFELSE(H>=REF(H,1)&&H>=REF(H,2)&&H>=REF(H,3)&&H>=REF(H,4)&& H>REFX(H,1)&&H>REFX(H,2)&&H>REFX(H,3)&&H>REFX(H,4),HH,0);

  L1:=IFELSE(L<=REF(L,1)&&L<=REF(L,2)&&L<=REF(L,3)&&L<=REF(L,4)&& L

  H2:=BARSLAST(H1);

  L2:=BARSLAST(L1);

  H3:=REFX(REF(H1,H2),2);

  L3:=REFX(REF(L1,L2),2);

  H4:=ZIGZAG(H3,0,0);

  L4:=ZIGZAG(L3,0,0);

  H5:=VALUEWHEN(H4REF(H4,2),HH);

  L5:=VALUEWHEN(L4>REF(L4,1)&&REF(L4,1)

  POLYLINE(H5>0,H5,COLORRED);

  POLYLINE(L5>0,L5,COLORWHITE);

  DRAWNUMBER(H5<>REF(H5,1),H5,H5-L5,0,COLORMAGENTA);

  DRAWNUMBER(L5<>REF(L5,1),L5,H5-L5,0,COLORMAGENTA);

  D:=VALUEWHEN(ISLASTBAR,H5);

  E:=VALUEWHEN(ISLASTBAR,L5);

  DRAWNUMBER(LOW>0,D,D,0,COLORWHITE);

  DRAWNUMBER(LOW>0,E,E,0,COLORWHITE);

  DRAWTEXT(CROSS(CLOSE,H5)||CROSS(CLOSE,L5),L,'');

  DRAWTEXT(CROSS(H5,CLOSE)||CROSS(L5,CLOSE),H,'');

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|小黑屋|RBLUNTAN. ( 沪ICP备19041928号-2 )

GMT+8, 2020-9-25 13:51 , Processed in 0.029100 second(s), 24 queries , Gzip On.

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表