进入论坛
我想发表

分享期货波段买卖点指标公式源码,适合短波,据说胜率99%!

交易所+1分钱超低手续费,跳1个点就轻松盈利-急速期货开户(附:期货手续费一览表


  我来为大家分享一个期货波段买卖点指标公式源码,它比较适合短线和波段的交易者,并且据说这个指标的胜率高达99%!由于本人也不太写指标,所以具体细节也不太清楚!

  如果是这方面的高手,可以留言,说明一下具体回测效果~

分享期货波段买卖点指标公式源码,适合短波,据说胜率99%!

  具体期货波段买卖点指标公式源码如下:

  VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;

  VAR2:=SUMBARS(VOL,CAPITAL);

  VAR3:=HHV(VAR1,VAR2);

  VAR4:=LLV(VAR1,VAR2);

  VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);

  VAR6:=(VAR1-VAR4)/(VAR3-VAR4);

  VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);

  VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);

  VAR9:=EMA(VAR8,7);

  VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;

  VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;

  波段买入: IF(VARA+VARB<7 AND CROSS(VAR8,VAR9) AND VAR9<-18 AND VAR9

  DRAWICON(波段买入=60,70,1),COLORRED;

  VARC:=HHV(HIGH,9)-LLV(LOW,9);

  VARD:=HHV(HIGH,9)-CLOSE;

  VARE:=CLOSE-LLV(LOW,9);

  VARF:=VARD/VARC*100-70;

  VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

  VAR11:=(2*CLOSE+HIGH+LOW)/4;

  VAR12:=SMA(VARE/VARC*100,3,1);

  VAR13:=LLV(LOW,34);

  VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);

  VAR15:=IF(VAR14>100,VAR14-100,0);

  VAR16:=HHV(HIGH,34);

  VAR17:EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);

  巫修全制: VAR17, ,COLORYELLOW ;

  VAR18:=EMA(VAR17,5);

  STICKLINE(VAR17>0 AND VAR17-VAR18>=0,79,80,6,0), ,COLORRED ;

  STICKLINE(VAR17>0 AND VAR17-VAR18<0,79,80,6,1), ,COLOR00FF00 ;

  STICKLINE(VAR17>0 AND VAR17-VAR18>=0,19,20,6,0),COLORRED, ;

  STICKLINE(VAR17>0 AND VAR17-VAR18<0,19,20,6,1), ,COLOR00FF00 ;

  STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1), ,COLORRED ;

  STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1), ,COLOR00FF00 ;

  VAR22:=REF(LOW,1);

  VAR23:=SMA(ABS(LOW-VAR22),3,1)/SMA(MAX(LOW-VAR22,0),3,1)*100;

  VAR24:=EMA(IF(CLOSE*1.3,VAR23*10,VAR23/10),3);

  VAR25:=LLV(LOW,30);

  VAR26:=HHV(VAR24,30);

  VAR27:=IF(MA(CLOSE,58),1,0);

  VAR28:=EMA(IF(LOW<=VAR25,(VAR24+VAR26*2)/2,0),3)/618*VAR27;

  VAR29:=IF(VAR28>100,100,VAR28);

  STICKLINE(VAR29>-150,0,VAR29,3,0), , COLORFF00FF;

  底部吸筹指标: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00;

  STICKLINE(CROSS(底部吸筹指标,-24),100,0,6,0), , COLORFFFFFF;

  先知: (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100, , COLORFF00FF;

  可能放量拉升: IF(CROSS(底部吸筹指标,-24),1,0), , COLORFFFFFF;

  VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

  VARK2:=REVERSE(VARK1);

  VARK3:=SMA(VARK1,3,1);

  波段王:=SMA(VARK3,3,1), , COLORRED,LINETHICK2;

  波段鬼:=SMA(波段王,2.5,1),COLORYELLOW,LINETHICK2;

  趋势线:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),,COLORFF6666,LINETHICK2;

  卖:IF((CROSS(波段鬼,波段王) OR CROSS(波段鬼,趋势线) OR CROSS(波段王,趋势线) ) AND波段鬼>65,90,0),STICK,,COLORFFFF00 ,LINETHICK3;

  RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K1:=SMA(RSV9,3,1);

  DK1:=K1-REF(K1,1),COLORSTICK;

  出手就赢:IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0),STICK,COLORYELLOW;

  DRAWICON(出手就赢>0,50 ,1);

  买点准备:IF(趋势线<=10,0,10), COLORFF9933,LINETHICK3;

  STICKLINE( CROSS(趋势线,10),0,73,6,0), COLOR3366FF,;

  DRAWTEXT(IF(CROSS(趋势线,10),100,0),68,'抄底'),COLORWHITE ;

  DRAWTEXT(IF(CROSS(10,趋势线),1,0), 10,'$备钱'),COLOR33FFCC,;

  {目前位置:

  对当前所处的技术位置进行评价,可对是否介入作出辅助判断}

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,3,1);

  D:=SMA(K,3,1);

  J:=3*K-2*D;

  DRAWTEXT(REF(J,1)<0 AND J>0,50,'短买'),COLORRED ;

  短线获利:STICKLINE(REF(J,1)<0 AND J>0,60,0,2,0),COLOR0000FF;

  目前位置:K;

  技术低位:20;

  技术中位:50,POINTDOT;

  技术高位:80;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

  DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

  以上就是“分享期货波段买卖点指标公式源码,适合短波,据说胜率99%!”的主要内容,希望可以对大家有帮助~

作者:
杨可帆

【版权声明】
1.本站文章禁止复制转载等一切途径,请广大粉丝注意,如果您喜欢RB,可以收藏本站,随时访问;
2.如标题下方的来源标识为“互联网”,则来源于网络其他平台,如对原著有冒犯之处可以联系RB,予以删除文章处理;
3.RB一切只为帮助广大交易者,所以大家可以通过心得文章多参考和借鉴,但是在实战交易中需要三思而后行,毕竟交易有风险,投资需谨慎;

RB螺纹钢期货论坛广告图

无需注册,留下你的观点
  • 全部评论(0
  • 游客留言:对期货小白来说,怎么导入到操作软件中。具体操作方法有吗? 管理员回复: 文华财经右上角有个系统工具,里面有个指标管理器,可以新建
  • 【推荐】与“期货波段买卖点指标公式源码”相关的文章