进入论坛
我想发表

通达信期货多空开仓源码,有能力的可以模拟测试下哦

交易所+1分钱超低手续费,跳1个点就轻松盈利-急速期货开户(附:期货手续费一览表


  指标说明及代码

  VAR1:=MA(LOW,1);

  VAR2:=MA(HIGH,2);

  VAR3:=MA(CLOSE,2);

  VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;

  VAR5:=SMA(VAR4,3,1);

  Y:SMA(VAR5,3,1),COLORRED;

  Y1:=SMA(Y,3,1);

  VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;

  YI: SMA(VAR6,3,1),COLORBLACK;

  Y2:=SMA(YI,3,1);

  VAR7:=REF(VAR3,1);

  VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;

  VARB:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;

  VARC:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;

  VARD:=CLOSE*100/MA(CLOSE,10)-100;

  VARE:=IFELSE(VARB>10,10,VARB);

  VARF:=IFELSE(VARE<-10,-10,VARE);

  VAR10:=IFELSE(VARC>10,10,VARC);

  VAR11:=IFELSE(VAR10<-10,-10,VAR10);

  VAR12:=REF(VARB,1);

  VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);

  VAR15:=REF(CLOSE,1);

  VAR16:=100*(CLOSE-VAR15)/CLOSE;

  VAR17:=MA(VAR13,3);

  VAR18:=MA(VAR16,3);

  VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6;

  VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;

  VAR1B:=MA(VAR1A,12);

  VAR1C:=EMA(VAR1A,5);

  VAR1D:=ABS(VAR1A-VAR1B);

  VAR1E:=REF(VAR3,1)*0.015;

  VAR1F:=REF(CLOSE,1);

  VAR26:=MA(CLOSE,26);

  VAR27:=VAR26+2*STD(VAR3,26);

  VAR28:=VAR26-2*STD(VAR3,26);

  VAR29:=VAR26+2*STD(REF(VAR3,1),26);

  VAR2A:=VAR26-2*STD(REF(VAR3,1),26);

  D1:=EMA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

  -2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5);

  D2:=REF(D1,1);

  STICKLINE(D1>=REF(D1,1),D1,D2,COLORBLUE,0);

  STICKLINE(D1

  QR:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100,COLORLIGHTGREEN;

  A:20,COLORMAGENTA;

  B:80,COLORCYAN;

【版权声明】
1.本站文章禁止复制转载等一切途径,请广大粉丝注意,如果您喜欢RB,可以收藏本站,随时访问;
2.如标题下方的来源标识为“互联网”,则来源于网络其他平台,如对原著有冒犯之处可以联系RB,予以删除文章处理;
3.RB一切只为帮助广大交易者,所以大家可以通过心得文章多参考和借鉴,但是在实战交易中需要三思而后行,毕竟交易有风险,投资需谨慎;

RB螺纹钢期货论坛广告图

无需注册,留下你的观点
  • 全部评论(0
    还没有评论,快来抢沙发吧!

【推荐】与“通”相关的文章